Stateless sorry-cypress deploy on heroku not working TypeScript

Summary

Deployed basic director service using Wiki document here, but when browsing deployed app I'm getting the following error: image

Going to Heroku logs I get the following messages: image

And running tests from CircleCI just gives me the following results: image

So the questions are: Am I doing something wrong? Is the wiki deploy button not deploying the right app with the right configuration? Am I missing some extra steps?

Need some help here, Thanks in advance!!!!

Asked Oct 08 '21 15:10
avatar carlos0202
carlos0202

6 Answer:

Thanks for the hard work @agoldis!

Sadly, I'm still facing errors while deploying the stateless director: image

1
Answered Jun 07 '21 at 17:37
avatar  of carlos0202
carlos0202

On it :) hold tight

On Mon., Jun. 7, 2021, 10:38 a.m. Carlos González, @.*> wrote:

Thanks for the hard work @agoldis https://github.com/agoldis!

Sadly, I'm still facing errors while deploying the stateless director: [image: image] https://user-images.githubusercontent.com/8674703/121064415-8e83f800-c795-11eb-8242-37acaa7e28c9.png

— You are receiving this because you were mentioned. Reply to this email directly, view it on GitHub https://github.com/sorry-cypress/sorry-cypress/issues/373#issuecomment-856132458, or unsubscribe https://github.com/notifications/unsubscribe-auth/AAMP4KDRP3ZSOSKVUP2DOKLTRT7YHANCNFSM46IAUEAQ .

1
Answered Jun 07 '21 at 17:49
avatar  of agoldis
agoldis

On it :) hold tight … On Mon., Jun. 7, 2021, 10:38 a.m. Carlos González, @.*> wrote: Thanks for the hard work @agoldis https://github.com/agoldis! Sadly, I'm still facing errors while deploying the stateless director: [image: image] https://user-images.githubusercontent.com/8674703/121064415-8e83f800-c795-11eb-8242-37acaa7e28c9.png — You are receiving this because you were mentioned. Reply to this email directly, view it on GitHub <#373 (comment)>, or unsubscribe https://github.com/notifications/unsubscribe-auth/AAMP4KDRP3ZSOSKVUP2DOKLTRT7YHANCNFSM46IAUEAQ .

Thanks!!!!! I'll be waiting (with fingers crossed included haha)

1
Answered Jun 07 '21 at 18:00
avatar  of carlos0202
carlos0202

https://github.com/sorry-cypress/sorry-cypress/commit/df4d2a62385a17ebd3d28ab75b647e5c0634529e didn't actually solve the build issues But https://github.com/sorry-cypress/sorry-cypress/commit/a658d3f34dd988a9b281dfbe659626473e47f665 did! Please try deploying the most recent version of master

1
Answered Jun 07 '21 at 18:01
avatar  of agoldis
agoldis

df4d2a6 didn't actually solve the build issues But a658d3f did! Please try deploying the most recent version of master

Deployed once again. Director finally got deployed, thanks!!!!

One last question because it's not clear in the docs. What's the correct way of configuring cypress agent runs in terms of projectId and key values? are they required?

1
Answered Jun 07 '21 at 18:33
avatar  of carlos0202
carlos0202

Updated https://docs.sorry-cypress.dev/guide/get-started

--key and projectId do not have any effect for the basic setup

1
Answered Jun 07 '21 at 18:44
avatar  of agoldis
agoldis